CVE-2025-58360
Published 2025-11-25 · Updated 2026-10-18 · Source security-advisories@github.com
Summary
CVE-2025-58360 is a high-severity (CVSS 8.2) vulnerability in OSGeo GeoServer. CISA added it to the Known Exploited Vulnerabilities catalog on December 11, 2025, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by January 1, 2026. CISA does not currently list it as used in ransomware campaigns. OSGeo has 3 vulnerabilities in the KEV catalog, 0 of them linked to ransomware.
All 3 known-exploited OSGeo vulnerabilities →Description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
CISA Known-Exploited Vulnerability
Product: OSGeo — GeoServer
Name: OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
Date added: 2025-12-11 · Due: 2026-01-01
Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

