CVE-2024-38856
Published 2024-08-05 · Updated 2026-06-17 · Source security@apache.org
Summary
CVE-2024-38856 is a critical-severity (CVSS 9.8) vulnerability in Apache OFBiz. CISA added it to the Known Exploited Vulnerabilities catalog on August 27, 2024, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by September 17, 2024. CISA does not currently list it as used in ransomware campaigns. Apache has 41 vulnerabilities in the KEV catalog, 8 of them linked to ransomware.
All 41 known-exploited Apache vulnerabilities →Description
Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA Known-Exploited Vulnerability
Product: Apache — OFBiz
Name: Apache OFBiz Incorrect Authorization Vulnerability
Date added: 2024-08-27 · Due: 2024-09-17
Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
References
- https://issues.apache.org/jira/browse/OFBIZ-13128
- https://lists.apache.org/thread/olxxjk6b13sl3wh9cmp0k2dscvp24l7w
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/security.html
- http://www.openwall.com/lists/oss-security/2024/08/04/1
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-38856

