CVE-2024-45195
Published 2024-09-04 · Updated 2026-06-17 · Source security@apache.org
Summary
CVE-2024-45195 is a high-severity (CVSS 7.5) vulnerability in Apache OFBiz. CISA added it to the Known Exploited Vulnerabilities catalog on February 4, 2025, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by February 25, 2025. CISA does not currently list it as used in ransomware campaigns. Apache has 41 vulnerabilities in the KEV catalog, 8 of them linked to ransomware.
All 41 known-exploited Apache vulnerabilities →Description
Direct Request ('Forced Browsing') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.16. Users are recommended to upgrade to version 18.12.16, which fixes the issue.
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CISA Known-Exploited Vulnerability
Product: Apache — OFBiz
Name: Apache OFBiz Forced Browsing Vulnerability
Date added: 2025-02-04 · Due: 2025-02-25
Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
References
- https://issues.apache.org/jira/browse/OFBIZ-13130
- https://lists.apache.org/thread/o90dd9lbk1hh3t2557t2y2qvrh92p7wy
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/security.html
- http://www.openwall.com/lists/oss-security/2024/09/03/6
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-45195

