HackerFeeds
All CVEs

CVE-2025-54068

CRITICAL9.8
CISA KEV

Published 2025-07-17 · Updated 2026-06-17 · Source security-advisories@github.com

Summary

CVE-2025-54068 is a critical-severity (CVSS 9.8) vulnerability in Laravel Livewire. CISA added it to the Known Exploited Vulnerabilities catalog on March 20, 2026, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by April 3, 2026. CISA does not currently list it as used in ransomware campaigns. Laravel has 3 vulnerabilities in the KEV catalog, 1 of them linked to ransomware.

All 3 known-exploited Laravel vulnerabilities →

Description

Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.

CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CWE-94

CISA Known-Exploited Vulnerability

Product: Laravel — Livewire

Name: Laravel Livewire Code Injection Vulnerability

Date added: 2026-03-20 · Due: 2026-04-03

Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

View on NVD