CVE-2021-21311
Published 2021-02-11 · Updated 2026-06-17 · Source security-advisories@github.com
Summary
CVE-2021-21311 is a high-severity (CVSS 7.2) vulnerability in Adminer Adminer. CISA added it to the Known Exploited Vulnerabilities catalog on September 29, 2025, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by October 20, 2025. CISA does not currently list it as used in ransomware campaigns.
All 1 known-exploited Adminer vulnerabilities →Description
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CISA Known-Exploited Vulnerability
Product: Adminer — Adminer
Name: Adminer Server-Side Request Forgery Vulnerability
Date added: 2025-09-29 · Due: 2025-10-20
Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
References
- https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351
- https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf
- https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6
- https://lists.debian.org/debian-lts-announce/2021/03/msg00002.html
- https://packagist.org/packages/vrana/adminer
- https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351
- https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf
- https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6

