CVE-2020-11023
Published 2020-04-29 · Updated 2026-06-17 · Source security-advisories@github.com
Summary
CVE-2020-11023 is a medium-severity (CVSS 6.9) vulnerability in JQuery JQuery. CISA added it to the Known Exploited Vulnerabilities catalog on January 23, 2025, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by February 13, 2025. CISA does not currently list it as used in ransomware campaigns.
All 1 known-exploited JQuery vulnerabilities →Description
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
CISA Known-Exploited Vulnerability
Product: JQuery — JQuery
Name: JQuery Cross-Site Scripting (XSS) Vulnerability
Date added: 2025-01-23 · Due: 2025-02-13
Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00067.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00085.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00039.html
- http://packetstormsecurity.com/files/162160/jQuery-1.0.3-Cross-Site-Scripting.html
- https://blog.jquery.com/2020/04/10/jquery-3-5-0-released
- https://github.com/jquery/jquery/security/advisories/GHSA-jpcq-cgw6-v4j6
- https://jquery.com/upgrade-guide/3.5/
- https://lists.apache.org/thread.html/r0483ba0072783c2e1bfea613984bfb3c86e73ba8879d780dc1cc7d36%40%3Cissues.flink.apache.org%3E

