HackerFeeds
All CVEs

CVE-2019-11580

CRITICAL9.8
CISA KEV

Published 2019-06-03 · Updated 2026-06-17 · Source security@atlassian.com

Summary

CVE-2019-11580 is a critical-severity (CVSS 9.8) vulnerability in Atlassian Crowd and Crowd Data Center. CISA added it to the Known Exploited Vulnerabilities catalog on November 3, 2021, which means exploitation in the wild has been confirmed; US federal agencies had to remediate it by May 3, 2022. CISA also lists it as known to be used in ransomware campaigns, so it should be prioritised accordingly. Atlassian has 14 vulnerabilities in the KEV catalog, 8 of them linked to ransomware.

All 14 known-exploited Atlassian vulnerabilities →

Description

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CISA Known-Exploited Vulnerability

Product: Atlassian — Crowd and Crowd Data Center

Name: Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability

Date added: 2021-11-03 · Due: 2022-05-03

USED IN RANSOMWARE

Required action: Apply updates per vendor instructions.

View on NVD